Python

tomato 中编译安装M2Crypto

首先从官网查询到M2Crypto最新版本为0.21.1,其基本需求为:

0.21.1: Python 2.3 or newer m2urllib2 requires Python 2.4 or newer OpenSSL 0.9.7 or newer Some optional new features will require OpenSSL 0.9.8 or newer SWIG 1.3.28 or newer required for building SWIG 1.3.30 or newer may be required with Python 2.5 or newer and Python 2.4 with Py_ssize_t patches

<p>
  安装SWIG,ipkg install swig即可搞定。
</p>

<p>

CentOS编译安装node+npm+obfsproxy

这三者的用途嘛,懂的自然懂,不懂的也不需要去懂,无需多说。

下面就开始:

首先是编译安装node和npm

git clone git://github.com/joyent/node.git cd node ./configure make install cd .. git clone git://github.com/isaacs/npm.git cd npm make install

CentOS 6.2安装Python2.7.3

首先查看当前系统中的python版本

系统默认python版本

1、安装开发工具

yum groupinstall "Development tools"

<p>
  2、安装其它需要的包
</p>

<div id="scid:9D7513F9-C04C-4721-824A-2B34F0212519:9aaa0b69-d5e1-4858-98a4-bd5c951fcd90" class="wlWriterEditableSmartContent" style="float: none; padding-bottom: 0px; padding-top: 0px; padding-left: 0px; margin: 0px; display: inline; padding-right: 0px">
  <pre style=" width: 640px; height: 25px;background-color:White;white-space:-moz-pre-wrap; white-space: -pre-wrap; white-space: -o-pre-wrap; white-space: pre-wrap; word-wrap: break-word;overflow: auto;"><div>

<!–

Code highlighting produced by Actipro CodeHighlighter (freeware) http://www.CodeHighlighter.com/

–>

RT-N66U+tomato编译安装gevent及pyOpenSSL

先来看一下官方对gevent的介绍

gevent is a Python networking library that uses greenlet to provide a synchronous API on top of libevent event loop. Features include: Fast event loop based on libevent (epoll on Linux, kqueue on FreeBSD). Lightweight execution units based on greenlet. API that re-uses concepts from the Python standard library (e.g. Event, Queue). Cooperative socket and ssl modules. Ability to use standard library and 3rd party modules written for standard blocking sockets (gevent.monkey). DNS queries performed through libevent-dns. Fast WSGI server based on libevent-http.